0

Vem ser Back-end!

#Lógica de Programação
Belisnalva Jesus
Belisnalva Jesus

Pessoal estou amando Lógica de Programação, pois são os princípios básicos da Computação.


Porque aprender Algoritmo e pseudocódigo?

  • Ajuda no raciocínio lógico;
  • aprimorar o nosso projeto passo a passo;
  • e executá-lo diariamente se torna mais fácil o aprendizado.


Vamos juntos nesta jornada?


Entendendo o que é ser Back-end.

BACK-END é responsável por cálculos, lógica de negócio, interações de database e performance. É tudo que o usuário não consegue ver.


Portugol é um pseudolinguagem que permite ao leitor desenvolver algoritmos estruturados em português de forma simples e intuitiva, independentemente de linguagem de programação.


Definição:

ALGORITMOS são conjuntos de passos finitos e organizados que, quando executados resolvem um determinado problema.


Como proceder:

  1. Pare e pense o que você quer fazer;
  2. Com auxílio de um livro e mais algumas pesquisas relacionadas ao seu curso, por exemplo "Algoritmo";
  3. Faça um rascunho do seu projeto;
  4. Com o Projeto já em mente, é só praticar;
  5. Reescreva agora no seu computador usando os códigos que o você aprendeu.


veja um exemplo simples:

Programa

{


Funcao inicio()

{

escreva("Saudações ou título")

var

inteiro

caracter

cadeia


escreva(" ")

}

}


Fim


Exemplo prático:

Programa

{


funcao inicio()

{

escreva("Saudações Alunos \n")

escreva("Vamos aprender juntos? \n")


inteiro CPF

caracter nome

cadeia Profissao


escreva("Digite o seu CPF: ")

leia(CPF)

escreva("Digite o seu nome: ")

leia(nome)

escreva("Digite a sua Profissao: ")

leia(Profissao)

}

}

Fim


Bom amigos, espero que vocês tenham gostado do meu "Artigo". Em breve postarei mais...

Conto com o apoio e compartilhamento de todos vocês!

Um forte abraço,


Atenciosamente,


Belisnalva C.P. Jesus

0
30

Comentários (0)

Estudante de TI - SPTech Back-end

Brasil