1

Tabuada Completa em Portugol

#Lógica de Programação
Carolina Lima
Carolina Lima

Oie, tudo bem pessoal? Criei um programa para consulta da tabuada completa em portugol e achei interessante compartilhar com vocês!

Usei a estrutura de decisão para perguntar ao usuário se ele desejava visualizar a tabuada e o comando "para" duas vezes, um interno ao outro, para assim variar os dois fatores.

//Função do programa: Consultar tabuada completa 
//Por: Carolina Coutinho

programa
{
	funcao inicio()
	{
		inteiro principal, fator
		cadeia resposta

		escreva("Bem-vindo(a)! Deseja consultar a tabuada completa? (s/n) ") 
		leia(resposta)
		
		se(resposta == "s")
		{
			escreva("\n****TABUADA****\n\n")
			para(principal = 1; principal <= 10; principal++)
			{ 
				para(fator = 0; fator <=10; fator++)
				{
					escreva(principal + " X " + fator + " = " + principal * fator + "\n")
				}
				escreva("\n")
			}	
		}
		senao
		{
			escreva("\nOK! Saindo...")
		}	
	}
}

Se souberem jeito melhor de fazer adoraria saber. Espero ajudar, até :)

3
36

Comentários (3)

0
Guilherme Guidolin

Guilherme Guidolin

29/06/2021 19:06

Boa Carol, gostei do artigo, ficou bem organizado.

0
Lorrayne Coelho

Lorrayne Coelho

29/06/2021 18:56

Eu fiz mais parecido com o do professor.

{

funcao inicio()

{

inteiro contador,limite,resultado,tabuada

contador=0

limite=10


escreva("Qual tabuada você quer que eu resolva?")

leia(tabuada)


faca {

resultado = tabuada * contador

escreva(tabuada + " x " + contador + " = " + resultado + "\n")

contador ++

}enquanto (contador<=limite)

}

}

0
G

Guilherme Silva

29/06/2021 18:47

Que legal ;)

Almejando o desenvolvimento Full Stack!

Brasil