0

Meu projeto no Portugol

Leonardo Silva
Leonardo Silva

Bom noite!! Gente!!

Essa semana, eu fiz uma calculadora só operações de multiplicação, mas estou muito feliz com o resultado e quem quiser me ajudar para melhorar, como fazer para ser uma calculadora completa.



	
	funcao inicio()
	{
	     real multiplicando,multiplicado,resultado
		escreva( "digite o multiplicando:" )
		leia(multiplicando)
	     escreva( "digite o muliplicado:" )
		leia(multiplicado)
		resultado = (multiplicando * multiplicado)
		escreva(" O resultado é:"  + resultado)
	}
}



0
0

Comentários (2)

1
Cledson Paranhos

Cledson Paranhos

16/07/2021 21:41

programa {

funcao inicio() {

  inteiro opcao

real num1, num2,resultado

escreva( "digite o primeiro numero:" )

leia(num1)

   escreva( "digite o segundo numero:" )

leia(num2)




escreva( "Selecione uma opção: \n")

escreva( "[1] - Soma\n" )

  escreva( "[2] - Subtração\n" )

  escreva( "[3] - Multiplicação\n" )

  escreva( "[4] - Divisão\n" )

  leia(opcao)

  escolha(opcao){

    caso 1:

      resultado = (num1 + num2)

      escreva("O resultado é:" + resultado)

      pare

      caso 2:

      resultado = (num1 - num2)

      escreva("O resultado é:" + resultado)

      pare

      caso 3:

      resultado = (num1 * num2)

      escreva("O resultado é:" + resultado)

      pare

      caso 4:

      resultado = (num1 / num2)

      escreva("O resultado é:" + resultado)

      pare

      caso contrario: escreva("Opção invalida!")

  }

}

}


Realizei essa implementação porém tem outras maneiras até melhores, nesse caso ai o usuário entra com os valores e logo após seleciona o tipo de operação. Bons estudos! 🚀


1
Fernanda Oliveira

Fernanda Oliveira

16/07/2021 23:05

Muito legal, parabéns!!

Trainne em desenvolvimento de software

Brasil