0

Implementação do JPA

#JPA #Spring Boot #MySQL
Breno Mendes
Breno Mendes

Ola eu me chamo Breno , e venho dar mais uma dica mega importante , se você está no modulo


#Trabalhando com Banco de Dados utilizando JDBC e JPA#

talvez você está enfretando problemas, verifique os passos que você deve verificar

  • saiba que o projeto que instrutor está mostrando é java 11 porem a pode conflitar com a versão da gradle verifique que tanto gradle como sdk estão atualizados
  • na pasta Resources \ META-INF \ , o arquivo persistence.xml verifique se as class estão estanciadas conforme seu pacote que elas estão localizadas
  • Verifique nas configurações do Hibernate dentro xml se o dialect está atualizado ou seja a ultima versão , colocando mesma versão que no curso , com toda certeza que não irá funcionar


	Esta configurações servem tanto para parte 1 como parte 2 desse modulo 
    
    caso não fique claro porque você deve deixar dialect na ultima versão segue o link do stackoverflow falando sobre esse problema

https://stackoverflow.com/questions/43716068/invalid-syntax-error-type-myisam-in-ddl-generated-by-hibernate

2
57

Comentários (2)

0
Breno Mendes

Breno Mendes

24/02/2021 14:17

Sim sim , sempre vou dar essas dicas porque passei horas e as vezes dias para descobrir o que era , starkovewflow nem se fale srsrsrs

1
Alan Pacheco

Alan Pacheco

22/02/2021 00:21

Muito obrigado pela observação. Chegarei lá e de olhos abertos.srsr..

Aplication Developer Jr

Brasil