0

Gradle Wrapper

Juliana Neves
Juliana Neves

Segui o passo a passo do instrutor na aula de Java Basico, mas na hora de fazer o wrapper deu erro. Alguem sabe resolver ? (obs. o mvn funcionou sem problemas)

0
0

Comentários (7)

0
Reginaldo Araújo

Reginaldo Araújo

14/07/2021 11:34

Estava com o mesmo problema, e consegui resolver movendo a pasta zip do gradle para dentro da pasta OTP, e depois executando o comando unzip -d /opt/gradle gradle-7.1.1-bin, quando executei gradle wrapper no terminal dentro da pasta otp, deu BUILD SUCCESSFUL.

0
Maria Moura

Maria Moura

14/07/2021 01:37

Ola. Eu não estou em conseguindo criar o diretório /opt porque diz que ele já existe. Só que ele não está no diretório onde baixei os arquivos. Alguém pode me ajudar?


0
Juliana Neves

Juliana Neves

07/07/2021 16:31

Quando eu coloco gradle -v ele retorna sem erro. Mas continua sem funcionar o wrapper.

Vou instalar o IDE já que me disseram que ela faz isso automaticamente.

Agradeço a cada um que me respondeu por aqui.

1
Thiago Oliveira

Thiago Oliveira

07/07/2021 03:44

se estiver usando uma ide, tipo intellij, ele faz isso automatico pela ide, nao precisa usar CLI

1
G

Gabriel Santos

07/07/2021 06:45

Consegue postar o --stacktrace e o --info dele? Pode ser em um Pastebin para ficar mais fácil de ler (se precisar de uma ajuda, posso ajudar).

1
Geovane Oliveira

Geovane Oliveira

07/07/2021 06:23

Juliana, segue o passo a passo de como instalar o Gradle no Ubuntu.

Eu particularmente não instalei pois na nova versão da IntelliJ já tem suporte ao Gradle nativamente.

Se precisar de mais ajuda, tem meu Instagram:

instagram.com/geovane.ads


---INSTALANDO GRADLE---


//baixar binary-only

https://gradle.org/releases/


//criar diretorio dentro da pasta OPT

mkdir /opt/gradle

//descompactar o gradle dentro da pasta criada

unzip -d /opt/gradle gradle-4.7-bin.zip

//ver se descompactou

ls /opt/gradle/gradle-4.7

//exportar para o PATH

export PATH=$PATH:/opt/gradle/gradle-4.7/bin

//verificar versao gradle

gradle -v


//wrapper de controler entre versoes do gradle em equipe

gradle wrapper

//ver versao do wrapper

./gradlew -v

2
R

Rogério Pereira

07/07/2021 04:02

Quando você executa o comando gradle -v e este comando funciona significa que o gradle está instalado corretamente.

O Gradle Wrapper é usado a nível de projeto (um projeto pré-existente) e este erro que está dando é porque ele precisa que exista um arquivo de nome settings.gradle

Procure entender a explicação sobre o motivo de se usar o wrapper e não se preocupe com a execução dele agora

None

Brasil