0

Atualizou para o 4.2 e está aparecendo este erro ao criar um novo projeto Kotlin?

#Kotlin #Android
Maycon Fuzita
Maycon Fuzita

Após atualizar o Android Studio para o 4.2 e criar um novo projeto Kotlin, me surgiu o seguinte erro:


A problem occurred configuring root project 'My Application'.
> Could not resolve all artifacts for configuration ':classpath'.
> Could not find org.jetbrains.kotlin:kotlin-gradle-plugin:1.5.0-release-764.
 Searched in the following locations:
   - https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.5.0-release- 
764/kotlin-gradle-plugin-1.5.0-release-764.pom
   - https://repo.maven.apache.org/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.5.0-release-764/kotlin-gradle-plugin-1.5.0-release-764.pom
 Required by:
     project :

Possible solution:
- Declare repository providing the artifact, see the documentation at 
 https://docs.gradle.org/current/userguide/declaring_repositories.html


Tentei diversas soluções sem sucesso...mas enfim encontrei uma!!! Talvez de certo para vocês também!


Segue a solução que funcionou:


Local: build.gradle (Project)


Onde está:

buildscript {
    ext.kotlin_version = "1.5.0-release-764"
    repositories {
        google()
        mavenCentral()
    }


Altere para

buildscript {
    ext.kotlin_version = "1.5.0"
    repositories {
        google()
        mavenCentral()
    }


E sincronize o gradle novamente!


Abraços!!

0
13

Comentários (0)

Formado em Sistemas de Informação, apaixonado por tecnologia, música e fotografia, tenho me empenhado e direcionado meus estudos para seguir a carreia de TI

Brasil