0

Desafio Tecnológico algoritimo

Daniel Ribeiro
Daniel Ribeiro

Pseudocódigo:

Emprega uma linguagem intermediária entre a linguagem natural e a linguagem de programação para descrever algoritmos.

           Exemplo:

INICIO

leia nota1

leia nota2

media= ((nota1+nota2)/2)

Se media <= 6

escreva (“Aprovado”)

Se não

escreva (“Reprovado”)

FIM



Exemplo 1 (if/else);

algoritmo "ex34"

// Função : A escola \u201cAPRENDER\u201d faz o pagamento de seus professores por hora/aula. Faça um algoritmo que calcule e exiba o

           // salário de um professor. Sabe-se que o valor da hora/aula segue a tabela abaixo:

           // Professor Nível 1 R$12,00 por hora/aula

           // Professor Nível 2 R$17,00 por hora/aula

           // Professor Nível 3 R$25,00 por hora/aula

// Seção de Declarações

var

nivel, horas: inteiro

inicio

// Seção de Comandos

escreval(">>>>> Escola APRENDER <<<<<")

escreva("Digite o nível do professor (1/2/3): ")

leia(nivel)

escreva("Digite o número de horas trabalhadas: ")

leia(horas)

 

se nivel = 1 entao

   escreval("O professor ganha",horas*12)

senao

   se nivel = 2 entao

       escreval("O professor ganha",horas*17)

   senao

       escreva("O professor ganha",horas*25)

   fimse

fimse

 

fimalgoritmo

 

  

Exemplo 2 (if/else);

algoritmo "ex33"

// Função : Escrever um algoritmo que leia três valores inteiros e verifique se eles podem ser os lados de um triângulo. Se

           // forem, informar qual o tipo de triângulo que eles formam: equilátero, isóscele ou escaleno

// Seção de Declarações

var

la, lb, lc, triangulo: inteiro

inicio

// Seção de Comandos

escreva("Digite o lado A do triângulo: ")

leia(la)

escreva("Digite o lado B do triângulo: ")

leia(lb)

escreva("Digite o lado C do triângulo: ")

leia(lc)

 

se la < (lc+lb) entao

   triangulo <- 1

senao

   se lb < (lc + la) entao

       triangulo <- 1

   senao

       se lc < (lb + la) entao

           triangulo <- 1

       fimse

   fimse

fimse

 

se triangulo = 1 entao

   se la = lb entao

       se lb = lc entao

           escreval("É um triângulo equilátero!")

       senao

           escreval("É um triângulo isórcele")

       fimse

   senao

       se lb = lc entao

           escreval("É um triângulo isórcele")

       senao

           escreval("É um triângulo escaleno")

       fimse

   fimse

fimse

 

fimalgoritmo


0
5

Comentários (0)

Programador, Web design, Atendimento ao cliente · Diretor administrativo · Administrador

Brasil