0

Clone da Netflix - Problema: IMAGEM DE CAPA SÓ FUNCIONA NO LIVE SERVER

Y
Yuri Silva

Bootcamp Localiza - Projeto: Clone da Netflix

Link do meu Repositório Git Hub:

https://github.com/yurikgs/modelo-clone-netflix.git


Galera se alguém souber me ajudar com esse problema, serei grato! Também aceito ideias para melhorar o projeto em geral...

No meu caso, mantive a ideia original do projeto, de criar um modelo editável de site de streaming, baseado na Netflix, porém com algumas melhorias, como o menu fixo dinâmico e transição da imagem de capa em degradê.

PROBLEMA: No momento, estou tentando resolver um problema relacionado com a linkagem da imagem de capa da seção "destaques". Está linkada na classe css ".destaques" em "main.css" com o endereço url() partindo da própria pasta do projeto, mas isso acaba só funcionando quando eu rodo a página a partir do Live Server / VS. Mas a imagem não roda quando eu abro a página diretamente pelo navegador, a menos que eu mude o endereço url para partir do meu computador, completo, estilo "C:..." . Segue o código em questão para melhor compreensão;


--> FUNCIONA (A IMAGEM RODA) NO LIVE SERVER, NÃO FUNCIONA NO NAVEGADOR:


" .destaques { font-size: 20px; background: linear-gradient(to bottom, var(--pretoTransp1), rgba(0,0,0,.4) 82%, var(--preto)), url("/img/matrix-filme.jpg"); "




--> FUNCIONA NO NAVEGADOR(NO MEU COMPUTADOR, CLARO, O CAMINHO VAI DEPENDER DA SUA MÁQUINA), NÃO FUNCIONA NO LIVE SERVER:


" .destaques { font-size: 20px; background: linear-gradient(to bottom, var(--pretoTransp1), rgba(0,0,0,.4) 82%, var(--preto)), url("C:/Users/Mário/Documents/03 ESTUDO/9_PROJETOS/PROJETOS_INFO/Site de Streaming (estilo netflix)/img/matrix-filme.jpg"); "



Vlw!

1
11

Comentários (3)

0
Y

Yuri Silva

11/09/2021 16:11

Luanna N. funcionou! Resolvido, muito obrigado! Obrigado também Marcelo Dantas, acho que o que vc queria dizer era igual ao da Luanna tbem... vlw

1
Luanna N.

Luanna N.

11/09/2021 14:27

O problema está no seu link. Você disse que a imagem estava aqui => /img/matrix-filme.jpg


Só que ela não está aí. Ela está 1 nível acima. Ponha ../img/matrix-filme.jpg que deve funcionar.


Se minha resposta te ajudar, marque ela como útil.

Cuide-se bem!

1
Marcelo Dantas

Marcelo Dantas

11/09/2021 10:58

tenta colocar o endereço começando com "./" se não me engano com esta alteração vai funcionar.

None

Brasil